Как vundle рассматривает нарушения, если использует конфигурацию со ссылками на репозитории git?

Если я это сделаю :PluginUpdate , как я могу быть уверен, что разработчики плагинов, перечисленных в .vimrc как ссылки на репозитории git, не обновили свои репозитории с нарушением изменений?

Например, я использую ссылку на репозиторий « Plugin 'tpope/vim-fugitive' и я не хочу, чтобы эта зависимость вносила изменения при следующем обновлении.

В целом, разработка плагинов vim влечет за собой соглашение о том, чтобы не вносить изменения в последнюю master ветвь? Я сомневаюсь, что такая конвенция существует, но все-таки существует ли политика для vim-плагинов, чтобы избежать нарушения конфигурации с обновлением плагинов?