Intereting Posts
Защищает ли git от несанкционированного изменения репозитория? Как мне получить файлы, специфичные для моего проекта, в подмодуле git? Запрос Git pull (Github) – где он сливается? Добавлен файл с 'git add', но не отражен в 'git diff' Каков наилучший способ развернуть код из репо и Ansible? Как я могу искать проблемы Github, связанные с закрытыми или закрытыми Почему я должен комбинировать код и тесты в одном коммите? показать разницу между фиксацией Свяжите и выполните внешний файл JavaScript, размещенный на GitHub Как мне лучше управлять git-репо для github-страниц, в которых используется йомен? Git проверить, есть ли выдающиеся коммиты для толкания Как объединить 2 ветки в git, сохраняя изменения только из одной ветви Как сравнить локальное репо между удаленным репо? Проверьте каждую ревизию с помощью Subversion? ветви, не появляющиеся в новом удаленном «gitlab»,

Git Push Heroku Master – Неудача?

поэтому я попытался нажать это приложение на герою:

https://github.com/harrystech/prelaunchr 

Я использую virtualbox с ubuntu.

я установил ruby, используя это:

 $ sudo apt-get install curl # Required $ curl -L get.rvm.io | bash -s stable # Get RVM $ source ~/.bashrc # Reboot the shell $ rvm requirements # To get the command below $ sudo apt-get install build-essential openssl libreadline6 libreadline6-dev curl git- core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt-dev autoconf libc6-dev ncurses-dev automake libtool bison subversion # Install Libraries $ rvm install 1.9.3 # Install ruby v1.9.3 $ rvm use 1.9.3 $ gem install rails # Install rails (I had to run this command twice. Error trying to find railties the first time.. weird) 

Однако, когда я создаю приложение heroku и пытаюсь нажать приложение, он дает мне эту ошибку:

 http://pastebin.com/uF5PUsCM 

для базы данных я установил postgresql (не знаю, имеет ли он какое-либо значение)

Предполагая, что git push heroku действительно нажимает на герою (git remote -v подтверждает это), сообщения об ошибках:

  Running: rake assets:precompile DEPRECATION WARNING: You have Rails 2.3-style plugins in vendor/plugins! Support for these plugins will be removed in Rails 4.0. Move them out and bundle them in your Gemfile, or fold them in to your app as lib/myplugin/* and config/initializers/myplugin.rb. rake aborted! refer/cream-tooltip@2x.png isn't precompiled 

Вы можете найти несколько предложений в « Ruby on Rails Rake assets: precompile error » и в этом выпуске :

Откройте config/environments/production.rb и убедитесь, что для следующей опции установлено значение true:

 # Don't fallback to assets pipeline if a precompiled asset is missed config.assets.compile = true config.serve_static_assets = true 

Затем выполните:

 rake assets:precompile --trace RAILS_ENV=production 

Проверьте также свои драгоценные камни .